Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
TVMC and amcodec
#1
I suggest at the admin to "order" at their developers to include the ''amcodec'' in the
next update of the TVMC  because it has much much better results with the old tv's!!
in SPMC and in the  fork spmc called FTMC of Feaktab with the amcodec eveything is much smoother!
it needs although more improvements with the quality !
now for the end..... happy China's new year !

Smile Heart Smile
Reply
#2
Admin - I wholeheartedly agree with Gatos , LibreELEC uses amcodec in its Kodi builds , and as you know (I am sure you have tested LibreELEC yourself?) , works so very well..

Is there a reason you are not using amcodec in your TVMC Builds? - You developers must know its better than the Surface Codec you use at the moment?

Again , we say this , because we want to make your Boxes better - which will result in better sales for you..

Regards

Friz
Friz's Nexbox File Repository:
https://mega.nz/#F!F9xjTSSa!R0vJfTC2U6Qc2skNMrr1iQ
Friz's Nexbox A95x (s905x), A1/A3 Facebook Page: 
https://www.facebook.com/groups/Nexboxcrazy/
Friz's SmallRT X1 , X2 , X3 Facebook Page:
https://www.facebook.com/groups/Smallrt
Reply
#3
I tried FTMC build 19 & 20 so to test but won`t install.
I`ll try updating SPMC to see if amcodec is there and if there is a difference.
On the other hand my preinstalled kodi works OK with dc:amc-h.264 or dc:amc-h.264 (S) (surface)
Will test and post back.
Reply
#4
Do we have a download link for the "official" TVMC that Nexbox are talking about?
Friz's Nexbox File Repository:
https://mega.nz/#F!F9xjTSSa!R0vJfTC2U6Qc2skNMrr1iQ
Friz's Nexbox A95x (s905x), A1/A3 Facebook Page: 
https://www.facebook.com/groups/Nexboxcrazy/
Friz's SmallRT X1 , X2 , X3 Facebook Page:
https://www.facebook.com/groups/Smallrt
Reply
#5
I updated the SPMC from google store to latest.
Cleared cache & data.
No amcodec mentioned.

     

So FTMC won`t install, SPMC no amcodec, I do not want libreelec anyway, it seems I have no comparison.
What should mention as a codec  pressing O in keyboard ?
Reply
#6
You must do a clean install on both FTMC and SPMC to see the amcodec!
not over existing kodi (ftmc) and not use the same settings file on both of them!
also must have the expert mode!


Attached Files Thumbnail(s)
   
Reply
#7
I had cleared data of SPMC so it does not keep anything. Then updated to the latest version through Google Play.
No amcodec.

Now I cleared data of SPMC, uninstalled it, double checked with Root Browser the .smpc folder is deleted, fresh install SPMC through Google Play.
As always changed to expert mode.
Went to accelaration. No amcodec.
Changed skin to confluence. Still no amcodec.

When you say I must do a clean install on both FTMC and SPMC to see the amcodec do you mean that if FTMC is not installed then  no amcodec is present even on SPMC?
Then it must be the FTMC adding that codec to the system.

Then again if I have to uninstall kodi so to install FTMC it is a no go. I don`t want to mess my kodi installation.
FTMC as a fork should  install without having to do with kodi. As SPMC does.
When I tried to install FTMC I got a message app was not installed.
So FTMC has a long way till it gets a proper fork. Which it seems it is not a fork but a modified kodi if you have to uninstall kodi so to get installed.
Reply
#8
Anyway, I feel sorry I can`t test it.
It sounds very interesting that`s why I started installing stuff. I would love to see the difference in either quality or performance (cpu usage / temps)

In next box I will try to find the time to taste it by myself.

Good find Gatos.
Reply
#9
You can go in Android/Data/ rename the "org.xbmc.kodi" to let's say "org.xbmc.kodi1" and unistall the existing kodi and install one of the 2 forks!
you'll see then the amcodec
you can always unistall them again and install the first kodi or the new tvmc and rename again the "org.xbmc.kodi1" to "org.xbmc.kodi" and you'll have your kodi settings back!
Reply
#10
It`s kind weird but finally I got amcodec listed.

After uninstalling kodi, no .kodi file present, installing FTMC, no amcodec.
Funny, no matter what I get no amcodec.

And finally...

I installed a modded firmware with much help from Gatos814.
I unpacked a nexbox A1 firmware made some little modifications and repacked it.
I mention it cause I think that`s the culprit in the case.

Using the pre-installed kodi I noticed low cpu usage but some dropped frames.
I got into video settings to adjust the zoom mode to stretch to 16:9
Accidentally messed the de-interlace setting and some other that could not remember and I found no setting for defaults.
So I cleared kodi data.

After this got into playback to change from mediacodec surface to mediacodec.
Then I discovered the amcodec was finally present.

But no matter if I set only one active, either mediacodec or amcodec I see the same low cpu usage and dislike the playback as it is not smooth as I`m used to with my normal A1 setup.
I`m going to experiment a little more.

So I guess it has to do with the modification of the firmware.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
TV Box News