Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
A95X 2G/16G Play Store will not load apps, need ROM
#1
I've got some sort of clone tv box, it reads OTT TV BOX AMLOGIC S905W Model:R1.

I bought it from wish. It's got 2 usb, one microSD, an Ethernet port and HDMI on it. In about media box in Android (7.1.2) it says Model A95X-R1, Build: A95X_R1-7.1.2-201710141428.

I can't seem to verify much about this box. I see a chip that says "SK Hynix H26M520033EQR e-NAND 426A M12JE573A04" then one "sci" chip (I can't read the rest ATM I'll have to pull out my microscope if needed) and the main board says A95XA1_V1_0 (near the HDMI). The MAC on the wifi chip comes back from smartchip integrated inc. The MAC on my Ethernet comes back from Shenzen CYX Technology Co, LTD.

Also AV port and SPDIF port, forgot those in the OP
Reply
#2
Problem resolved. Will backup ROM now with TWRP and try to post it.
Reply
#3
(01-12-2018, 01:00 AM)engineerchad Wrote: Problem resolved. Will backup ROM now with TWRP and try to post it.

What did you do? A Firmware flash?
If yes, which firmware image did you use?
Reply
#4
I ended up finding a version of play store to install to the box that worked. I'm zipping up the backed up (close to original) boot, data and system images I got with a TWRP backup, I'll place it on my OneDrive and post a link tonight or tomorrow to it. I'll throw in the factory recovery that I pulled as well. If you Google TWRP a95x, the version I used was 3.0.2 for the lollipop version of the firmware but it worked in the case of this box, also.
Reply
#5
https://1drv.ms/f/s!AtYTbQWzzbfRiBZEsUFK73q2H-pX

Semi original firmware. I'm not sure how to make a flashable file from this. I can try to pull it with dd in a terminal if that would be more useful?
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
TV Box News