Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Mecool KIII pro hdmi output failure
(10-16-2018, 12:15 PM)gatos814 Wrote: Hmm....
Did you test it with other HDMI cable?
Did you test it in other TV?
Did you change the resolution from the settings?
Did you try it after a factory reset?
Tell me what things have you done from these!

Gatos, I tested other cables, other tv. also tried to change resolution from settings. and I tried to make several times factory reset from settings. all effort was failed. still black screen on HDMI. now I am using my box wit AV connection with bad resolution 576i almost double less from HD.
I have also this tv box with this firmware first installed :
and after that with OTA updated to 20171013 !
I have used many custom firmwares without anything like that !
Anyway , since everything was working ok before ,i assume that you might have missing something here !
Maybe completely random you facing some hardware problem !
Maybe you have to try with ''erase all'' on burning tool before flashing it (You probably loose L1 DRM but there is a patch fixing it again!) !
Try to use your tv box with another power adapter!
Beware it needs 12v and over 1.5A!
You can use some things here to see if the HDMI working of not (hardware problem) !
Try to use a working TWRP recovery for this tv box , inside an sd card and see if that boot (and you have a visual of the screen) into the recovery menu!
Try also without a TWRP to see, always via HDMI, if you can access the native recovery menu !
Good luck!
Let me try to explain the situation I met before three weeks ago.
When I saw the new firmware on xda froum (the latest one), I downloaded it and put it on USB stick. I tried to install this upgrade when the box current firmware was 6.0.1 marsmallow (20170527 very stable one) . While it was been installed almostt 20 %, upgrade process was stopped and gave a E3004 error which was written on screen in recovery mode as "E3004 this package is for KIII PRO. Yourdevice is KIII PRO_DDR_3G".
So I decided to try installing process via put in recovery mode using tooth-stick method. But when I try this, maybe I hardly remember that I can put stick not reset hole but near the air holes. I am not sure this can cause the screen lost. after that HdMI screen gone but box lights was on. Then I did all directions that you mentioned previous posts. All flashed roms that I used USB tool method, run without problem. I realized that machine runs without any problem. This is my background that I lived for this box not mentioned before.
your suggestion about trying with ''erase all'' on burning tool before flashing it, how can I do this step by step?
In usb tool configuration section on the right change the ''normal erase'' to ''erase all''
and flash the firmware i gave you !
Feedback the results!
Good luck!
(10-17-2018, 12:39 PM)gatos814 Wrote: In usb tool configuration section on the right change the ''normal erase'' to ''erase all''
and flash the firmware i gave you !
Feedback the results!
Good luck!

I did your way exactly. Now my box runs with your rom. I can show you my process with some pictures. I did update thru OTA update. After all your process (all I did this on AV connection), I connected my box to HDMI cable. my sony Tv recognized the HDMI connection automatically. But still damn no image came thru.. Confused Angry Angry
[Image: 9][Image: 15vk0g.jpg][Image: 2hd9ybk.jpg][Image: 29mae7q.jpg]
So,you're one step closer but not 100%!
I think now is good time to test again with other cables and tv
Also look in the settings for the CEC control or if the resolution is ticked in auto mode !
Finally try again the burning procedure, just in case....!
Good luck!

Forum Jump:

Users browsing this thread: 1 Guest(s)
TV Box News