Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Nexbox A95x (s905x) Android 6.0 FAQ - Part 3 - **Updated April 30th 2017**
Note: Due to board restrictions on posting images - this FAQ is split into multiple parts.

This is part 3 of the FAQ.

Q: Is there any way to add a external antenna to my A95x to improve its Wifi performance?.

A: Yes , Forum user Kodiloaded has posted the following procedure - all credit must go to him for posting it:


List of what you will need

1: 2.4Ghz Antenna & Pigtail
2: Soldering Iron and rosin core solder for electronics
3: Drill or Dremel to make hole
4: Needle nose pliers to fasten pigtail to box
5: Magnifying glass or bifocal glasses, Very small area your soldering and wires are tiny
6: Razor blade to trim antenna wire.
7: Small jewelers tool screwdriver or like object to pry open box
Bottom cover rear of box you will see a notch, This is where to pry it open.


1: Carefully pry open box from bottom starting at rear center where you see the little notch.
2: Remove 4 small Philips screws that hold PCB to case, Peel off internal antenna & remove PCB.
3: Drill hole in left side of box as seen in photos where the notch is on the PCB
4: Carefully Desolder internal antenna wire
5: Strip and solder pigtail wires to PCB
6: Insert & fasten pigtail to box
7: Reassemble




[Image: image.jpg]


[Image: image.jpg]

[Image: image.jpg]


[Image: image.jpg]


[Image: image.jpg]


[Image: Before.png]


[Image: After.png]


Original Thread Here

Custom Firmware for Nexbox,KdLinks,Himedia and many more.

Q: I use the Xfinity TV App on my Nexbox , but it refuses to run , as I understand it checks for Root and HDMI. Is there a way to make it work on my device?.
A: Forum user Kodiloaded has written this superb tutorial , so that you can enjoy this app on your device. Note: You must have brought the paid service to be able to use this App - this is NOT an illegal app.

This is how to bypass Xfinity TV App check for Root and HDMI Output, Confirmed working on NeXbox with Android 6.

FULL  ROOT REQUIRED inc SuperSU from Chainfire (See FAQ item below on how to install this)

A95X S905X 1G-8G , 2G-8G and 2G-16GB.



Install the 3 apps included in the download. and make sure you have the latest ver of the Xfinity TV App already installed.

Step:1 Open Xposed Installer app Click on Install and Reboot when asked.

Step:2 Open Xposed Installer Again, Top left click the 3 Bars, Then Modules, Tick the box for RecieverStop & RootCloak and reboot again.

Step:3 Open RootCloak Click Manage Apps, Top right click the 3 dots choose clear all apps, Once clear click the + and select TV, and exit app.

Step:4 Open RecieverStop, Select TV and then click android.intent.action.HDMI_PLUGGED, It will turn red

Reboot once more and now Xfinity app will work..

You should be able to use the same method for any apps that check for 

HDMI & Root.

You may get an odd error # the first time you try to load a channel 

just reboot again.

You can download from the Link Kodiloaded has provided here:

Alternate Download is the Nexbox A905x Repository located here:
Files needed to use Xfinity TV App on a Nexbox


Q: I understand that my Nexbox A95x (s905x) is not FULLY rooted , and needs a additional app. Where can I find this?  and how do I install it.
A: Forum user Kodiloaded has provided some info on this:

1) Just make sure you use SuperSU by Chainfire, this can be found here below. The link my vary slightly depending on your country:
SuperSU By Chainfire
2) Install it, Open it up, select Expert, Continue. Then Install In Normal Mode, 
3) Reboot.

Q: Sometimes, videos on my A95x seem to play very dark. Is there any kind of Fix or Workaround for this?
A: Until this is fixed by Nexbox in Firmware , forum user Aleksey has a solution that he says is permanent:

"For permanent fix dark video do following:

You find any short videofile (15-25 sec) (.mp4 work perfect). Change his name to bootvideo and place it in 

Set permission 644 (rw-r-r)

You set permissions using the "root Browser" app on your A95x. Long press tapping the file (long press OK or long press left click if having a mouse) will open an advanced options menu. 

There you choose "permissions" and you can set the "permisson 644 (rw-r-r)"

In file 

find string service.bootvideo=0 and change it to service.bootvideo=1

Press to open the file build.prop and choose "open as" and it will pop up a menu, choosing open with "RB text editor" you can edit the file.

Note: when changing permissions on a file you have to reboot so to take effect. In this mod you have anyway to reboot but assuming you added a keylayout.kl file or other and you changed the permission then you have to reboot to make the new permission active.

Every reboot you will see this video and after system startup, there no problem with dark video at all."

An example video file can be found here:
Sample Video file for Dark Video Fix

Or at the Nexbox File Repository:
Sample Video file for Dark Video Fix

Q: I see many adverts/commericals appearing in many apps these days eg Mobdro,Showbox etc etc. Is there any way to shop these appearing on my device.
A: Yes , forum user Kodiloaded has kindly provided a procedure to fix this:

"Are you tired of all the ad's in Mobdro, TerrariumTV, Megabox, Showbox Etc, Then you need AdAway.

AdAway is an ad blocker that uses the hosts file. The hosts file contains a list of mappings between host names and IP addresses. When an app requests an ad, that request is directed to which does nothing


SuperSU by Chainfire (See other FAQ item by Kodiloaded on how to install this).


Install AdAway, When you open the app accept superuser request , Click Download files and and apply ad blocking, It will ask if you would like to reboot but there is no need to.

Enjoy being ad free...."

Download AdAway

Q: Is there a way to Remap the remote control buttons (eg Live TV) on my Nexbox?
A: Yes , thank to forum user Kodiloaded , we have a procedure to do this.

"This will allow you to designate any button on the remote to an app or function of your choice.

Install Multilanguage Keymap Redefiner from the google play-store its free, This will allow you to remap any key you like on the factory remote or any other device you use on the A95X, It will take you a bit to figure it out but its fairly simple.

Once installed open it up and follow the instructions to set it up, After that then go to MKR settings, In settings Tick the boxes for Show Applications & Show System Apps, Now go back to main window and at the top choose AML_KEYPAD#1, now at the bottom left of screen click Add Remapping, It will then ask you to press the button you want to remap, Once you do that just click on the remap in the main window and set it to whatever app you want.

I hope this helps you out !"

Q: Is there a way to Hide the Android Navbar at the bottom of my A95's screen?, I find it very annoying.
A: Yes , forum user Kodiloaded has provided a procedure to do this.

"If you are like me and cant stand the NavBar at the bottom of your screen there is an easy way to disable it.

Requires root.

Install build.prop Editor Here From Google Play

Scroll all the way to the bottom of the buildprop and add this as the bottom line

qemu.hw.mainkeys = 1

Be sure to save changes

Reboot and no more Navbar

Be very careful not to change anything else, Or your device may no longer boot and you will have to reinstall firmware !

To re enable Navbar simply remove the entry you added and reboot."

More items will be added to this FAQ in the coming days...

[b]Q: Is there a way to install SamsMC Kodi Wizard on my Nexbox?[/b]
[b]A: Yes , forum user SamsMC , has posted a tutorial on how to do this for Kodi 16.1.[/b]

"Based on Kodi 16.1

1:   Click on the link to download the apk
2:   Make sure you are connected to WiFi or lan
3:   After the installation and you open the app , click on samsMC. Close the first run screen.  Press the samsMC Icon. 

IMPORTANT: When it is finished installing it will tell you to force close the app. Either power the box off and back on, Or simply unplug the power cord to the box and plug it back in. This is very important!  

4:  Click on the App and you are finished!!!


Thank You!

I will update my build about every week. Simply uninstall the app and reinstall and you will get my latest build!"


Q: Is there a way to totally shut off my A95x , without just pulling the power cord out?
A: The Red button on the A95x's remote is a "Suspend" button (ie it just puts the unit to sleep) - this is achieved by a quick press of the Red button on the remote control. A full power off is achieved by holding down the Red button on the remote , until a confirmation dialogue appears on screen , hit "OK" on the remote and the unit will switch off. There is also a app called "Reboot Manager (root)" available at the Google play store. This will allow you to totally shutdown or just reboot your A95x. See below for the link in the store , which may vary due to your country / language.
Reboot Manager For Shutdown

Q: For various reasons I need to fully "Un-Root" my device. Can someone outline the procedure to do this?.
A: Forum user Jfath has given us a procedure to do this:

Install superSU from the play store.
Install JRummy busybox from the play store.
Install JRummy root checker from the play store.
Run superSU, go to settings and choose full unroot.
Run JRummy busybox and choose 'uninstall'.
Your box should now be completely unrooted.  You can verify using JRummy root checker
If you want to root again, but hide it from Netflix, use Magisk and phh's Superuser as described in part 1 of the FAQ

Q: My Lan/Wan keep dropping randomly , do we know why and is there any type of fix for this?
A: Thanks to Forum users JRem85  and Spiros , we think this is caused by a DCHP conflict. When the A95x goes into Suspend mode and then when woken up ,has a IP address that's been taken by another device. The Fix for this would be allocating a Static IP address to your A95x via your router settings. So it always has the same IP address from your router.

Q: I have updated my firmware and now my box has defaulted to a different language that I cannot understand. How can I get back to my default language?.
A: Forum user Davey , has the answer for us here:

Go to Settings>HDMI CEC , if CEC control is set to enabled. Then change the "Auto change language" option to "NO"

Q:Can I watch 4K Youtube content on my TV Box?

A: Yes , Thanks to forum user Kodiloaded , who has posted a procedure to do this:


This is a modified you-tube that allows you to view 4K content on any device as well as download right from the you-tube app itself.

Step1. Download and install microG for OGYouTube

Step2. Download and install OGYouTube

Note: These files are also available at the Nexbox Repository , but its suggested that you always go to the above
links to get the very latest versions.
4K Youtube Apps Mirror

Q:The Version of Kodi that came with my Nexbox is full of Addons I dont use. Is there a way to do a "Clean Install"?
A: Thanks to forum user Gatos814 , we have a procedure to clean and reinstall the same version of Kodi that came with your Nexbox. The Kodi button on the remote and Home screen Icon etc will not be affected by this clean install:

"For better experience erase the installed kodi version and clean your tv box

after that install this version (it's the same with the one you had but without all these ,sometimes useless apps)
now just run the "KodiCenter" and reinstall all the apps you realy needed!
you'll see a great difference!

The File needed is mirrored here at the Nexbox File Repository:
Kodi reinstall File Mirror

Q:I have A95X S905X (2G, 16G, marshmallow) box, with the lastest available firmware, custom recovery and magick flashed. I can not write from any apps running on box to my USB stick, neither to the external SD-card, both of them FAT formatted. I've found this by trying to make a backup from Kodi. Has anyone had the same type of problem and does someone have solution or a workaround ?
A: Forum user Mrbabyqc found that this is NOT a Nexbox bug , but more a limitation of Android 6.0 Marshmallow. He found some solutions/workarounds here
Workarounds for SD card writing problem

Q:I hear that the operating system LibreELEC can be run from SD card or installed perminatley on my A95x. Is there a procedure todo this?
A: Forum user DanielZanchi has taken the time to produce a really great tutorial on this:

How to install LibreELEC on Tv Box with S905 or S905X CPU on MicroSD / USB

Note: Q: What is this LibreELEC?
          A: Its is a operating system that will run on your A95x , with Kodi Built into it. All you will get is Kodi , nothing more , no Android apps or other features. Many people have reported Kodi works much better on LibreELEC , and videos etc play much more smooth. This is the reason why many users use it and like it.

Note 2: If you decide to Permanently install LibreELEC  on your A95x (as opposed to just running/booting it from SD card. You will no longer be able to use the Android features of your device. And will need to totally reinstall the A95x Firmware should you decide to return your device to its original condition. **USE AT YOUR OWN RISK**. If you do "flash" it to internal memory by accicdent , and you have one of the Nexbox devices that DOES NOT have a reset switch. Thee is a procedure at the bottom of this article that will help you.

Itis HIGHLY suggested that you perform a TWRP backup before flashing/installing anything to your A95x , that way you can "recover" to a backup should anything go wrong or you should wish to return your A95x to its original state. Details on TWRP can be found elsewhere in this FAQ. If you have one of the Nexbox devices WITHOUT  a reset switch , then it is suggested to Flash TWRP to internal memory. As you will NOT be able to boot it from SD card unless you have a reset Switch.

In this guide you will be able to install LibreELEC on MicroSD / USB without touching Android OS or the original firmware. 
LibreELEC is a OS that runs only Kodi. It runs faster and as you turn on your TV Box you will find Kodi.

I did this on my A95X with CPU S905X. It runs very good and it enables (if you need) the Force RGB option for old TVs.
I suggest to install to the main Memory (Nand) or to run it on a very fast MicroSD.

1. You will need the tool to write the image of LibreELEC on the MicroSD (or USB), downloads: WindowsMacLinux-32 BitLinux-64 Bit
2. Insert the MicroSD (or USB) on the computer and run "LibreELEC USB-SD Creator" (run as Administrator). You should see this:

[Image: AX6iNLNm.jpg]

3. Download the LibreELEC file from here: LibreELEC (you can check an updated version here, I wouldn't install alpha versions)
4. On the "LibreELEC USB-SD Creator" click on Select File and select the image that you downloaded before.
5. ATTENTION all the files on your MicroSD will be deleted!  Select the MicroSD under the 3. Don't select other drives here! 
6. Click on Write and wait till it finishes writing.
7. If your box has a S905X CPU jump to n. 8. If your box has S905: Remove the MicroSD / USB and plug it back in to the computer, go to the root of the MicroSD / USB and copy one of this file inside it, renaming it as dtb.img and removing the existing one. Of those files download the one that seems more close to your box. 1 GB of Ram or 2 GB.
8. The MicroSd / USB is ready. Insert it into the TV Box and boot it into Recovery mode (unplug the power press the reset key hidden under the AV plug with a toothpick and plug the power keeping the reset key pressed until it loads). If you are using a USB and it doesn't load into recovery mode try using a different USB port.
9. Once inside recovery mode with your remote select reboot. Your TV Box should load LibreELEC.

If you have an old TV and it presents the handshake problem with green screen you should enable the Force RGB option. 

1. Enable SSH connection from the LibreELEC settings on the TV Box
2. Check the IP address of the Box from connection
3. From your computer open Terminal for MAC and Linux or Start - Run - CMD for Windows.
4. Connect to your TV box (user root): ssh root@
    This is a MAC command. Check for windows or linux on how to connect via SSH.
5. insert the password: libreelec
6. Run: 
cd .config

7. This starts an editor. Insert the following text:


echo 1 > /sys/class/amhdmitx/amhdmitx0/output_rgb

8. Save with the same name
9. Run:

chmod 755

Now you have the RGB enabled. 

You can check by doing steps 1 to 6 to check if the file was saved.

1. Run steps from 1-5 of "Enable RGB tutorial"
2. Run: 

3. The box will reboot and you can remove your MicroSD / USB. It will load from internal memory.

Let me know if you have any problems. I will try to help!

I did this because a lot of users have the green screen problem and LibreELEC solved it. I tried the October, Nov, Dic official firmware for the A95X box but even enabling the "Force RGB" option didn't help.

UPDATE Jan 3rd 2017:

If by accident , you happen to "Flash" LibreELEC to internal memory , and then cannot access recovery (Where you may have TWRP installed)  and you have one of the Nexbox units that DOES NOT have a reset switch. Connect to your unit using the SSH Client PuTTY ( ) and then issue this command: reboot recovery , you unit should then reboot back into TWRP where you can recover to a backup of the Android file system if needed.

Q: When I go to use the Netflix App on My Nexbox , I get a 0013 error , is there any fix or workaround for this?
A: Yes , thanks to forum user Jayort and Michael Bray (Via Youtube) we have a fix:

1. Open a root file browser
2. Go to /system/vendor/lib
3. Rename to e.g. libdrmdecrypt.soX
4. Reboot your device 
5. Give Netflix a try
More items will be added to this FAQ in the coming days...

Q: Is there a list of which USB wired , and Bluetooth game controllers work on the A95x?

A: Yes , thanks to forum user duboisbrain , we have a short list. If users would like to PM myself (friz) with others controllers that work or do not work. We can then add to the Faq.

Xbox wired controller (works)

Xbox one bluetooth controller (works on bluetooth model)

Tronsmart mars g1 controller wireless plug in and play (works)

Cheap snes usb controller (does NOT work)

Ps3 Controller works in Bluetooth Mode

Ps4 controller bluetooth (does NOT work, doesnt connected??)
Ps4 controller wired (does NOT work)

Q: I have created a "Restricted Profile" on my device , but appear to be locked into it ie I cannot switch back to my regular profile. Is there any fix for this?
A: Yes , thanks to forum user Ins0mniac, follow this procedure to delete the restricted profile. Note , this is only a temporary fix until Nexbox decide to fix this correctly in a firmware update. But at least it means you will not have to do a factory reset , which deletes all your user data.

Note , this is a time sensitive procedure , you will have to be very quick , and it may take a few times to get your timing right.
1) Pull the power cable on your device , re-insert it and allow your device to boot.
2) As soon as the main screen is up , quickly navigate to: settings/security & restrictions/restricted profile
3) Delete your Restricted profile (you'll have a very short amount of time to put in your 4 digit code for this to work before it switches back to restricted profile).
4) Reboot your device.
5) Your restricted profile will be gone , but at least now you can actually use your device.

Q: Teamviewer Remote control does not work on the A95x, is there any fix or workaround for this?

A: Yes , thanks to forum user Jovanka we have a fix:

Teamviewer Remote control not working on A95X S905X 2/16 

Test bed: Fully stock 29112016 ROM, A95X 2/16 - (probably applicable to 1/8, 2/8 S905X models)

The Required Apk's can be downloaded here , at Friz's Nexbox repository:!hoJgVBZa!2M2o-ykD2MU2I8vXjbIGIw
Upon install of the Teamviewer QS from the Google play, remote control tab/option was not available is on the client connecting to the A95X  nor it was providing with an option to install additional addon( just an windows stating „ device is on  ASOP platform and compatible, feel free to open the link... „  ending up with the option to open a support ticket with the Teamviewer). Specification on the Teamviewer state that for the Android and TVQS on the ASOP platform prerequisite is rooted device,  which partially A95X is.
1.      Install SuperSu from Google Play and apply it and reboot the device
2.      Copy attached APKs to the A95X
3.      Install the TVQs.APK
4.      Start TeamviewerQS from APPS on A95X
5.      Enter TV ID from A95X  on the client you are conecting from, connec to the A95X device from the other client
6.      Finally „REMOTE CONTROL“ tab is visible
7.      Trying the „REMOTE CONTROL“ tab gave me an error message stating „Your device is compatible but there is no addon installed, do you want to install?“ 
8.      Click Yes. Auto download of the QsAddon.apk starts and finishes, „Do you want to install“, again click Yes, Finish
9.       Exit TVQS, 99% sure that no reboot will be needed
10.  Start the TVQS again, enter the new ID on the client you are connecting from
11.  Tab „Remote control“ still here, click it and it works!  <3 PS Expect some lag while using it (feature, not a bug)

2nd method
1.      Install SuperSu from Google Play and apply and reboot the device
2.      Install the TVQs.APK
3.      Install the QsAddon.APK
4.      Start the TVQS, enter the ID on the client you are connecting from
5.      Tab „Remote control“ visible,  click it and it works!  PS Expect some lag while using it (feature, not a bug)
6.      It should work
Q: Is there a procedure to upgrade the version of Kodi (16.1) that came with my box , to the newer 17.1 Krypton Build?

A: Yes , thanks to Facebook Group member Eric De Schepper , we have a procedure:

TV Box: NexBox A95X 1/8 Clone.

The box came with some custom (not NexBox) firmware. The box is also missing the NexBox logo.

Verified hardware specs are compatible and downloaded cyx_NEXBOX-A95X_S905X_s9082c_8189etv_8g1g_kodi_addons_161125_SD_USB.rar from Friz's Nexbox Repository. Installed via toothpick method. Firmware installed successfully and box now displays A95X and NexBox logo on startup.

Removed all downloaded (pre-installed) Android apps (Netflix etc.) but for Kodi (16.1). (I have no use for the other Android apps, I only use Kodi, FilmOn.TV (I have a subscription), Exodus, Radio and Yahoo Weather) with the Xonfluence skin (hellyrepo).

Ran Kodi 16.1 and installed all repositories and addons used by me. 

Exit to launcher.
Downloaded Kodi 17.1 apk (32bit) from and installed via Android app manager.

App manager asked if I wanted to upgrade (states: no information will be lost).

After successfull install/upgrade, ran Kodi 17.1 which automatically migrated database and addons (This takes a while, there is a visual stating Kodi is migrating addons).

Upon full Kodi 17.1 startup, greeted with new Estuary skin and a couple notices: "addon marked as incompatible/broken. Disable addon?". Answered "NO" to all questions, ignored all warnings, removed or changed nothing, went to settings and changed skin to Confluence (I wasn't going to bother figuring out the new interface at this point in time).

Adjusted some 3rd party repositories to Krypton (eg: SuperRepo, TVaddons, etc.) and forced addon update(s) in system/addons.

All addons and libraries updated successfully.

Restart Kodi.

All addons working, all settings migrated ( database, debrid account, timezone, etc).

Received a request from Friz check if Kodi button still works on remote. Dug up original remote and tested. Kodi button works, firing up Kodi 17.1 from launcher.

Upgrade from Kodi 16.1 to 17.1 successful. Addon upgrades successful after adjusting some 3rd party repositories to Krypton (17.1).
Q: I just brought a New A95x , and it does not look like TVMC (Kodi) or other apps are installed on the main page of the launcher?. Is there any Fix or workaround for this?

A: Yes , thanks to Facebook Group member Colin. We have a solution.

It seems that with the New March release of the A95x Firmware , we can switch interfaces , from one where it appears TVMC (Kodi) is NOT installed, to one where it IS installed. The new units have a slightly different remote control shipped with them. What used to be the "Kodi" button is now a "Help/Thumbs up" button. To switch the interfaces, simply hold this button down for about two seconds. The interface will change. Once its changed , a single swift press of this button , will launch TVMC just as it did with the old Kodi button. See links below for photos..

New Remote Control

Old Remote

Interface (No TVMC)
Interface (With TVMC)
Q: My Device seems to be "Bricked" , that is , it will not boot and only the Red light is showing , whatever I do, I cannot get it to boot. Is there a fix for this?

A: Yes, thanks to forum user Hardtecnica , we have a solution. The procedure involves re-flashing your device with a compatible firmware using the USB Cable method. Don load this before you start.

I made this USB A to A from spare cables because it's almost impossible to find it in a local store. I got my box successfully restored by USB burning tool, but it was not so easy as it seemed. Fisrt I marked the option 'Reset after Success" because it is marked on the tutorial doc, along with the "Erase Flash (normal erase)" and "Erase Bootloader" that are marked as default when the .img is imported.   I connected only the usb cable in the first port and it was getting error at 2% (I found that some people was getting this 2% error too in this forum). When I noticed that I had to connect the power cable too, so this time I was getting error at 4%, then, I just unmarked the "Reset after Success" option and left only the two other default options marked:  "Erase Flash (normal erase)" and "Erase Bootloader". By this way it finally worked. 

So, people just need to follow these steps:

1: Install the usb burning tool (available in Friz's Nexbox Repository) with administrator privileges and wait patiently at the end while it install the drives

2: Open usb burning tool with administrator privileges. Change language to English on the second tab.

3: Extract the firmware update you already downloaded into a folder and import the extracted IMG on "File>Import Image" tab.

4: Check if the "Erase Flash (normal erase)" and "Erase Bootloader" are already marked. Left only these options checked.

5: Connect the A95x to the power using his original or equivalent PSU (5v @2A).

6: Click on the big "Start" button

7: Connect the usb cable from pc to the A95X on his first USB port

8: Wait until it gets 100% with green confirmation on the burning tool, disconnect the usb cable, and only then stop and close the tool program.

This tutorial applies for the device: "A95X-B7N 2gb 8gb", it SHOULD work with oter A95x tv boxes but I cant guarantee.

Program version: USB_Burning_Tool_v2.0.5.15-build7
OS utilized: Windows 7 64bits.
Friz's Nexbox File Repository:!F9xjTSSa!R0vJfTC2U6Qc2skNMrr1iQ
Friz's Nexbox A95x (s905x), A1/A3 Facebook Page:
Friz's SmallRT X1 , X2 , X3 Facebook Page:
IPVanish is probably the best VPN service to use in order to watch movies and TV shows anonymously on Kodi or otherwise. But, Astrill VPN can be used by 5 persons or devices at the same time!

Forum Jump:

Users browsing this thread: 1 Guest(s)
TV Box News