Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Dark video problem fix - best workaround
#1
Exclamation 
For permanent fix dark video do following:

You find any short videofile (15-25 sec) (.mp4 work perfect). Change his name to bootvideo and place it in
Code:
\system\etc
directory
Set permisson 644 (rw-r-r)

In file
Code:
\system\build.prop
find string service.bootvideo=0 and change it to service.bootvideo=1
Reboot

Every reboot you will se this video and after system startup no problem with dark video at all.

You can find sample file in attach.


Attached Files
.zip   bootvideo.zip (Size: 531.65 KB / Downloads: 236)
Reply
#2
@Aleksey

Great work , and thank you so much for posting this. I know many users suffering from the Dark Video Bug will benefit from you sharing this. I would like to add this to my FAQ - of course I will give you the necessary credit.

But do you think you could explain a couple of things , for those among us that dont know how to:

1) "Set permisson 644 (rw-r-r)" - How do we do this? , what tools do we use?
2) "find string service.bootvideo=0 and change it to service.bootvideo=1" - aain , which tool do we use todo this..

Thank in advance

Friz
Friz's Nexbox File Repository:
https://mega.nz/#F!F9xjTSSa!R0vJfTC2U6Qc2skNMrr1iQ
Friz's Nexbox A1/A3. A95x (s905x) Facebook Page: 
https://www.facebook.com/groups/Nexboxcrazy/
Reply
#3
(12-14-2016, 06:32 PM)friz Wrote: @Aleksey
But do you think you could explain a couple of things , for those among us that dont know how to:

1) "Set permisson 644 (rw-r-r)" - How do we do this? , what tools do we use?
2) "find string service.bootvideo=0 and change it to service.bootvideo=1" - aain , which tool do we use todo this..

In A1 box there is a file explorer called "root browser". It has root access and has advanced options. I suppose A95X has the same app pre- installed.
Use this.

Long press tapping the file (long press OK or long press left click if having a mouse) will open an advanced options menu.
There you choose "permissions" and you can set the "permisson 644 (rw-r-r)"

Press to open the file build.prop and choose "open as" and it will pop up a menu, choosing open with "RB text editor" you can edit the file.

*when changing permissions on a file you have to reboot so to take effect. In this mod you have anyway to reboot but assuming you added a keylayout.kl file or other and you changed the permission then you have to reboot to make the new permission active.
Reply
#4
(12-15-2016, 04:55 AM)spiros Wrote:
(12-14-2016, 06:32 PM)friz Wrote: @Aleksey
But do you think you could explain a couple of things , for those among us that dont know how to:

1) "Set permisson 644 (rw-r-r)" - How do we do this? , what tools do we use?
2) "find string service.bootvideo=0 and change it to service.bootvideo=1" - aain , which tool do we use todo this..

In A1 box there is a file explorer called "root browser". It has root access and has advanced options. I suppose A95X has the same app pre- installed.
Use this.

Long press tapping the file (long press OK or long press left click if having a mouse) will open an advanced options menu.
There you choose "permissions" and you can set the "permisson 644 (rw-r-r)"

Press to open the file build.prop and choose "open as" and it will pop up a menu, choosing open with "RB text editor" you can edit the file.

*when changing permissions on a file you have to reboot so to take effect. In this mod you have anyway to reboot but assuming you added a keylayout.kl file or other and you changed the permission then you have to reboot to make the new permission active.

Many thanks for this Spiros..
Friz's Nexbox File Repository:
https://mega.nz/#F!F9xjTSSa!R0vJfTC2U6Qc2skNMrr1iQ
Friz's Nexbox A1/A3. A95x (s905x) Facebook Page: 
https://www.facebook.com/groups/Nexboxcrazy/
Reply
#5
Here is the solution of dark screen problem. You have to install SCREEN ADJUSTER and set contrast around -50. Also don't forget to turn on autorun in the settings (swipe from status bar). The only problem is that this app blocks install button (when you try to install any app). But if you are an experienced user and you have Xposed installed try also to install NoOverlayWarning module to disable this warning.
Reply
#6
(12-15-2016, 04:13 PM)jazzman_84 Wrote: Here is the solution of dark screen problem. You have to install SCREEN ADJUSTER and set contrast around -50. Also don't forget to turn on autorun in the settings (swipe from status bar). The only problem is that this app blocks install button (when you try to install any app). But if you are an experienced user and you have Xposed installed try also to install NoOverlayWarning module to disable this warning.

Jazzman_84, bootvideo solution is much better - work fine, don't block install button, don't need any Xposed modules.

(12-14-2016, 06:32 PM)friz Wrote: @Aleksey

1) "Set permisson 644 (rw-r-r)" - How do we do this? , what tools do we use?
2) "find string service.bootvideo=0 and change it to service.bootvideo=1" - aain , which tool do we use todo this..

Thank in advance

Friz

Use app Root browser from stock firmware.
Set 644 permission:
   
   

Changing build.prop with RB text editor:
   
   
Reply
#7
(12-16-2016, 08:10 AM)Aleksey Wrote:
(12-15-2016, 04:13 PM)jazzman_84 Wrote: Here is the solution of dark screen problem. You have to install SCREEN ADJUSTER and set contrast around -50. Also don't forget to turn on autorun in the settings (swipe from status bar). The only problem is that this app blocks install button (when you try to install any app). But if you are an experienced user and you have Xposed installed try also to install NoOverlayWarning module to disable this warning.

Jazzman_84, bootvideo solution is much better - work fine, don't block install button, don't need any Xposed modules.

For me bootvideo solution is not good because the contrast becomes badly calibrated. Black color becomes grey. The picture is too bright. Download some test pictures for calibration display contrast and you will see what I mean.
Reply
#8
(12-14-2016, 04:30 PM)Aleksey Wrote: For permanent fix dark video do following:

You find any short videofile (15-25 sec) (.mp4 work perfect). Change his name to bootvideo and place it in
Code:
\system\etc
directory
Set permisson 644 (rw-r-r)

In file
Code:
\system\build.prop
find string service.bootvideo=0 and change it to service.bootvideo=1
Reboot

Every reboot you will se this video and after system startup no problem with dark video at all.

You can find sample file in attach.

Thank you! Works great for me.
Reply
#9
Good job.
TVBoxNews.com, http://www.tvboxnews.com/
Reply
#10
thank you. solution works just fine. I didnt even changed the folder permission and it still worked. My box is nexbox a95X s905X_2gb_16gb_11051014
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
TVBoxNews.com